Videopac / Odyssey2 forum
April 10, 2020, 11:27:59 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: If you have some news and you want it to be shown here, pm Janzl!
 
   Home   arcade Help Login Register links videopac.nl  
Pages: [1]   Go Down
  Print  
Author Topic: Broken Odyssey2?  (Read 2361 times)
Ampersand
Trying to get the cartridge in...
*
Posts: 7


« on: October 02, 2010, 01:28:21 AM »

Hey guys.

I recently got an Oddyssey2 at a yardsale. However, I'm not sure what's wrong with it. The previous owner said the video was messed up. When I took it home and tried it, all I could get was a glitch screen, no sound. The screen is gray with random tiles/graphics, and it randomizes every time I turn it on. It also just displays a blank gray screen every so often.

Anyone know what's wrong with it? I'd like to fix it.

Or if anyone wants it, I could send it to you. It came with a fairly large collection of games, 16 or so, as well as some Odyssey2 magazines, the scorepad, etc.

Thanks!

-Amp
Logged
Ozyr
Totally devoted to Videopac
*******
Posts: 1508


Packrat Video Games


david.flemming.9
WWW
« Reply #1 on: October 02, 2010, 01:13:26 PM »

If the magazine are in good shape (or not), keep them. Score pad collectors item too! They are worth money!  Grin

As for the O2, I leave that to the experts here...
Logged

Ampersand
Trying to get the cartridge in...
*
Posts: 7


« Reply #2 on: October 02, 2010, 04:27:38 PM »

Oh cool. Both are in great shape, everything is really. The scorepad hasn't even been used, I think.
Logged
Rafael
Pedit5
I take the Videopac and leave the Canoli!
*
Posts: 2524



« Reply #3 on: October 02, 2010, 05:07:37 PM »

Not sure if it can help you, but sometimes, when I get some Odyssey like this I use to let it "working" around 15 minutes, sometimes it?s enough for it back?
Logged
Ampersand
Trying to get the cartridge in...
*
Posts: 7


« Reply #4 on: October 02, 2010, 05:43:20 PM »

What do you mean? Turn it on, and leave it for fifteen minutes?
Logged
Rafael
Pedit5
I take the Videopac and leave the Canoli!
*
Posts: 2524



« Reply #5 on: October 02, 2010, 06:04:52 PM »

What do you mean? Turn it on, and leave it for fifteen minutes?

Yes, Ampersand. Try it.
Logged
Ampersand
Trying to get the cartridge in...
*
Posts: 7


« Reply #6 on: October 02, 2010, 07:26:55 PM »

Tried, no luck  Sad
Logged
Rene_G7400
Pedit5
I take the Videopac and leave the Canoli!
*
Posts: 2519



WWW
« Reply #7 on: October 03, 2010, 12:21:45 AM »

Sounds like the computer can't read the cartridge. Maybe something wrong with the cartridge connector?
Logged
Ampersand
Trying to get the cartridge in...
*
Posts: 7


« Reply #8 on: October 03, 2010, 02:51:33 AM »

Perhaps, it is awfully dusty in there. I'll take it apart and clean the connector.

Dos/don'ts, anyone?
Logged
nathanallan
Trying to get the cartridge in...
*
Posts: 13



student42 Nathan Allan
« Reply #9 on: October 22, 2010, 08:38:32 AM »

Any luck? I tend to think it's a dirty cart connector, too.
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!