Videopac / Odyssey2 forum
August 22, 2019, 03:12:56 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Join Rafael's Haunted Woods contest and win a copy of the game!
 
   Home   arcade Help Login Register links videopac.nl  
Pages: 1 2 [3] 4 5   Go Down
  Print  
Author Topic: Merry Christmas - O2EM 1.20 (with C7420 emulation)  (Read 32589 times)
LS650
Played Munchkin once...
**
Posts: 53



« Reply #30 on: January 28, 2014, 04:42:13 AM »

I've been running v1.18 for a long time.  I tried this version and have to say I prefer it; I really like the built-in file loader rather than mucking about with the add-on frontends.

 Cool
Logged
daddy_scott
Freedom Fighter
****
Posts: 251


« Reply #31 on: January 29, 2014, 07:05:59 PM »

I've tried to use this and am having no luck.  I know it is an operator error rather than a software one.  I just don't understand code and scripts well enough, admittedly.

Are there instructions on using this program?  I have it downloaded and can get a screen to pop up, but that is about all I'm able to do.  If someone has step-by-step setup instructions, I would appreciate the help. 

While I love playing on my actual hardware, I can see sometimes playing on my computer too.
Logged
manopac
Game & App Development
Give this man a Jopac!
*
Posts: 1116



« Reply #32 on: January 30, 2014, 02:22:28 PM »

what exactly pops up? may help me to tell you what's going wrong ;-)

easiest thing is - run a command window (if you are running windows -> Start -> where it says "Search programs and files" type "cmd.exe" hit enter -> navigate to the directory you installed O2EM in (e.g. cd \emulators\o2em)
and type o2em -> hit enter and you will see the error message it says (most probably it is missing the system-rom ...)

Logged

sex, lies, and videopac
Rafael
Pedit5
I'd sell my mother for a Videopac
*
Posts: 2456



« Reply #33 on: February 23, 2014, 12:45:08 AM »

Some Vectrex emulators have a suport from Overlay (despite, I never understand how it works). Itīs possible to do it on O2em. The main objective is to load some images for plus graphics testings???
Logged
manopac
Game & App Development
Give this man a Jopac!
*
Posts: 1116



« Reply #34 on: February 24, 2014, 08:12:57 AM »

hm ... so you would want to be able to load a background image if the videopac+ mode is disabled? I currently don't really have time to work on it, but will put it on my to-do list ;-)
Logged

sex, lies, and videopac
19rsn007
Trying to get the cartridge in...
*
Posts: 8


« Reply #35 on: January 20, 2015, 10:02:08 PM »

sorry for this reply on an old topic.

Does anyone still have the source for this version ?
I wanna try to compile the thing for linux.
Logged
manopac
Game & App Development
Give this man a Jopac!
*
Posts: 1116



« Reply #36 on: January 21, 2015, 07:41:44 AM »

no problem ;-) I got you pm, but didn't get around yet to pack together everything you need - pm me your email address and I will try to send it today!
Logged

sex, lies, and videopac
19rsn007
Trying to get the cartridge in...
*
Posts: 8


« Reply #37 on: January 21, 2015, 11:18:21 PM »

no problem ;-) I got you pm, but didn't get around yet to pack together everything you need - pm me your email address and I will try to send it today!

Hey Manopac,

Gertk gave me the source and with a bit of tinkering with the makefile, I got it compiled and running in a native linux form Cheesy

after compiling I had to delete the .XML config file and just state my options in terminal (for c7420 that is), but eventually I got it working.


No for the next goal.....get the C7010 working Cheesy
Logged
19rsn007
Trying to get the cartridge in...
*
Posts: 8


« Reply #38 on: January 26, 2015, 10:05:03 AM »

more playing around with o2em....

This time I was looking into emulating the C7010.
Got it booting up, even got a game started, but lots of work to be done.

This NSC800 (a z80 comatible cpu) in the C7010 isn't emulated fully yet.
And O2EM needs some cycle accuracy tweaking.
But I actually got the C7010 emulation started Cheesy




so far I can boot O2EM with the C7010 VP rom (nothing special there)
I can start a game, seeing the checkerboard (still nothing special there)
I can start a chess game by pressing the N-key and select my skill (1-6)
Then the board is filled with characters....and as you can see the video isn't build up as should (yes I started O2EM with the -euro option to set it to european mode)
Then I can give the commands for moving a piece and from there on the emu crashes me back to terminal with an "unimplemented instruction"

So the start is there, but there is still a lot of work to be done.

this is what I get right now after trying to move a piece:
« Last Edit: January 26, 2015, 05:02:09 PM by 19rsn007 » Logged
goldenband
Trying to get the cartridge in...
*
Posts: 37


« Reply #39 on: January 30, 2015, 07:44:32 PM »

Hey, nice to see that C7010 emulation is actively being worked on!

FWIW MESS seems to be stalled at about the same place: you can start a game, and in the case of MESS the pieces seem to be correctly displayed, but the CPU will never make a move.
Logged
19rsn007
Trying to get the cartridge in...
*
Posts: 8


« Reply #40 on: February 02, 2015, 09:26:09 AM »

Hey, nice to see that C7010 emulation is actively being worked on!

FWIW MESS seems to be stalled at about the same place: you can start a game, and in the case of MESS the pieces seem to be correctly displayed, but the CPU will never make a move.

Yeah I tried it in MESS and noticed the exact same problem.
The computer never makes a move.

I did look into the code of mess a little, but even mess isn't really cycle accurate when it comes to O2 video timing.
Logged
goldenband
Trying to get the cartridge in...
*
Posts: 37


« Reply #41 on: February 03, 2015, 02:40:17 AM »

Yeah I tried it in MESS and noticed the exact same problem.
The computer never makes a move.

I did look into the code of mess a little, but even mess isn't really cycle accurate when it comes to O2 video timing.

That doesn't surprise me, but I figure the main issue is that the C7010 processor just isn't implemented at all -- the game looks for a brain, and doesn't find one. Kind of the opposite of the Scarecrow, I suppose.  Tongue
Logged
19rsn007
Trying to get the cartridge in...
*
Posts: 8


« Reply #42 on: February 03, 2015, 10:45:43 PM »

That doesn't surprise me, but I figure the main issue is that the C7010 processor just isn't implemented at all -- the game looks for a brain, and doesn't find one. Kind of the opposite of the Scarecrow, I suppose.  Tongue

the NSC800 is implented in MESS as far as I recall, but somehow it's not working properly.
Logged
Sorex
Trying to get the cartridge in...
*
Posts: 46


« Reply #43 on: February 16, 2015, 10:22:23 PM »

Hello,

Are there any known issues of roms that worked in 1.18 that are not working anymore in 1.20?

I'm setting up my development environment again after almost 7 years and I noticed this (old) update so I "installed" it here.

But one of my first tests back then, which is far from rocket science, is not doing anything in this "new" version although it works fine in 1.18.

Might be my code aswell tho, will dig into it.
Logged
Sorex
Trying to get the cartridge in...
*
Posts: 46


« Reply #44 on: February 16, 2015, 10:31:40 PM »

adding screen off & on kernal calls solved that problem.
Logged
Pages: 1 2 [3] 4 5   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!